
The Libreswan Project
SecurityEncrypting the Internet with IKE / IPsec VPN
Get involved
Links from the organization’s published listing (2026). Older contact links may have moved.
Programs & participation
7 records across 1 programIndexed project records; missing years are not zero. Coverage
2026Google Summer of CodeAnnual program · 3 projects indexed
- Add HOST-TO-HOST Support on BSD
- Add Support For Announcing Authentication Methods To Libreswan
- Optimising the lookup time for ACQUIRE messages sent by kernel
Source checked Sep 28, 2026
Participation imported from the GSoC Organizations archive snapshot; this historical listing is not an application-status claim.
2022Google Summer of CodeAnnual program
Project details are available from the participation source. This record does not list individual projects.
Source checked Sep 28, 2026
Participation imported from the GSoC Organizations archive snapshot; this historical listing is not an application-status claim.
2021Google Summer of CodeAnnual program · 1 project indexed
Source checked Sep 28, 2026
Participation imported from the GSoC Organizations archive snapshot; this historical listing is not an application-status claim.
2020Google Summer of CodeAnnual program · 3 projects indexed
- Add Support for RFC 5723 'Session Resumption' and RFC 6023 'Childless Initiation of SA'
- IKEv2 Interop testing with OpenBSD
- INTERMEDIATE exchange for IKEv2
Source checked Sep 28, 2026
Participation imported from the GSoC Organizations archive snapshot; this historical listing is not an application-status claim.
2019Google Summer of CodeAnnual program · 1 project indexed
Source checked Sep 28, 2026
Participation imported from the GSoC Organizations archive snapshot; this historical listing is not an application-status claim.
2018Google Summer of CodeAnnual program · 3 projects indexed
- Extend RFC-7427 Signature Authentication support to IKEv2 with ECC / EDDSA support
- Implementing “Group Key Management using IKEv2” IETF draft, RFC 5685 - “Redirect Mechanism for IKEv2” and/or RFC 5723 - “IKEv2 Session Resumption”
- Web based Certificate and Profile User Interface
Source checked Sep 28, 2026
Participation imported from the GSoC Organizations archive snapshot; this historical listing is not an application-status claim.
2017Google Summer of CodeAnnual program · 2 projects indexed
- Implement TCP Encapsulation of IKE and IPsec Packets
- RFC-7427 Signature Authentication support to IKEv2 for Libreswan
Source checked Sep 28, 2026
Participation imported from the GSoC Organizations archive snapshot; this historical listing is not an application-status claim.